Not logged in, Join Here! or Log In Below:  
 
News Articles Search    
 

 Home / General Programming / SDL and fmod linker errors Account Manager
 
Archive Notice: This thread is old and no longer active. It is here for reference purposes. This thread was created on an older version of the flipcode forums, before the site closed in 2005. Please keep that in mind as you view this thread, as many of the topics and opinions may be outdated.
 
hymerman

May 12, 2005, 11:37 AM

hey there, peeps :)

now, i know this is very, very n00bish of me, but i'm having a bit of trouble building a project with SDL and fmod in VC++.NET. in one file i've included sd.h, fmod.h and various other .h files that i need. in the options (tools->options->Projects->Directories) i've set the include and library directories to point to the include and library directories of SDL and fmod..... but for some reason when i compile i get a load of unresolved external symbols relating to SDL and fmod.

so, what have i done wrong? i thought this was all i had to do to get it working, but i guess not! please help a newbie in distress :)

thanks!

 
Chris

May 12, 2005, 11:40 AM

It's not enough to set the search paths properly.
You need to tell the linker to explicitly link against sdl.lib and fmod.lib (or whatever these .lib-files are called, I don't have them at hand).

So go to Project Settings, and list these libraries under Linker -> Additional Dependencies (or something similar, I've got a german version. Just go to that menu where you change all the compiler settings like optimization levels etc. Theres a linker entry in the tree to the left). There will probably be a list like "kernel32.lib user32.lib gdi32.lib" etc., just add your libs behind those.

 
hymerman

May 12, 2005, 07:04 PM

thank you very much :) i didn't know this. anyways, i found an 'additional dependencies' menu, but that only let me list directories, not individual lib files, so i tried that but it didn't work. in the end i used #pragma comment()s. anyways, that's all working fine for now, and it's not complaining about SDL or fmod, but it is complaining about windows... specifically, winmain. now, i was under the impression that SDL did all this for me, but i guess i was wrong. does anyone know what library file to include to get this error to go away?

note: i've just tried linking sdlmain.lib rather than sdl.lib, but it just tells me that a load of symbols are already defined...

 
This thread contains 3 messages.
 
 
Hosting by Solid Eight Studios, maker of PhotoTangler Collage Maker.