Not logged in, Join Here! or Log In Below:  
 
News Articles Search    
 

 Home / General Programming / Making software on OS-X, console annoyance Account Manager
 
Archive Notice: This thread is old and no longer active. It is here for reference purposes. This thread was created on an older version of the flipcode forums, before the site closed in 2005. Please keep that in mind as you view this thread, as many of the topics and opinions may be outdated.
 
chad

March 25, 2005, 02:29 PM

I have an OpenGL application from linux that I'm moving to OS-X (now uses carbon for windowing). It all works fine, except I have two questions, and google hasn't been helping me. :/

1. When I run the application from the GUI, with no terminal open, it opens a terminal just to run the application. This is pretty annoying, how can I have it not open any terminal at all to run it?

2. When I run the application, it opens up behind all the other currently opened windows. Why on earch is it doing this?

Thanks for any help

 
[-WD40-]

March 25, 2005, 05:00 PM

1. I presume you're using CodeWarrior and this is a setting you can remove, don't remember if it's in the project's settings or the IDE preferences.

 
chad

March 25, 2005, 07:29 PM

Actually, Im just using gcc & makefiles

 
[-WD40-]

March 25, 2005, 08:50 PM

do you happen to be using GLUT?

 
chad

March 26, 2005, 08:14 AM

Nope, using commands like CreateNewWindow, and then agl stuff to set up the context.

Any ideas?

 
Victor Widell

March 28, 2005, 06:45 PM

There should be a compiler switch to not open the terminal. Check the GCC docs.

 
This thread contains 6 messages.
 
 
Hosting by Solid Eight Studios, maker of PhotoTangler Collage Maker.